djDecks

It is currently Sat Oct 21, 2017 11:25 am
View unanswered posts
View active topics

All times are UTC + 1 hour




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Strange <invert> behaviour in tabs PostPosted: Mon Jul 16, 2012 9:22 pm 
Regular
User avatar

Joined: Mon May 08, 2006 5:51 pm
Posts: 338
It appears to be that crossfader is not able to invert using a tab.

Code:
   <input>
      <type>Button</type>
      <value>TabSelect</value>
      <valuespecifier>crossfader2</valuespecifier>
      <bytes_up>94 36 00</bytes_up>
      <bytes_down>94 36 7f</bytes_down>
   </input>
   
   <tabs>
      <tab>
      <name>crossfader1</name>
         <input>
            <type>Slider</type>
            <value>Crossfader</value>
            <bytes>b4 10 VV</bytes>
            <invert>yes</invert>
         </input>
      </tab>
      <tab>
      <name>crossfader2</name>
         <input>
            <type>Slider</type>
            <value>Crossfader</value>
            <bytes>b4 10 VV</bytes>
            <invert>no</invert>
         </input>
      </tab>
   </tabs>

This code is not working. It will stay inverted.



Next, linefaders:
Code:
   <tabs>
      <tab>
      <name>crossfader1</name>
         <input>
            <type>Slider</type>
            <value>Volume_Player</value>
            <bytes>B0 1C VH</bytes><bytes_low>B0 2C VL</bytes_low>
            <bytes2>B1 16 VH</bytes2><bytes2_low>B1 26 VL</bytes2_low>
            <bytes3>B2 1C VH</bytes3><bytes3_low>B2 2C VL</bytes3_low>
            <bytes4>B3 16 VH</bytes4><bytes4_low>B3 26 VL</bytes4_low>
            <invert>yes</invert>
         </input>
      </tab>
      <tab>
      <name>crossfader2</name>
         <input>
            <type>Slider</type>
            <value>Volume_Player</value>
            <bytes>B0 1C VH</bytes><bytes_low>B0 2C VL</bytes_low>
            <bytes2>B1 16 VH</bytes2><bytes2_low>B1 26 VL</bytes2_low>
            <bytes3>B2 1C VH</bytes3><bytes3_low>B2 2C VL</bytes3_low>
            <bytes4>B3 16 VH</bytes4><bytes4_low>B3 26 VL</bytes4_low>
            <invert>no</invert>
         </input>
      </tab>
   </tabs>

This code is working, but only for player0.

When splitting in multiple object like so:
Code:
   <tabs>
      <tab>
      <name>fader1</name>
      <default>yes</default>
         <input>
            <type>Slider</type>
            <value>Volume_Player</value>
            <bytes>B0 1C VH</bytes><bytes_low>B0 2C VL</bytes_low>
            <player>0</player>
            <invert>yes</invert>
         </input>
         <input>
            <type>Slider</type>
            <value>Volume_Player</value>
            <bytes>B1 16 VH</bytes><bytes_low>B1 26 VL</bytes_low>
            <player>1</player>
            <invert>yes</invert>
         </input>
      </tab>
      <tab>
      <name>fader2</name>
         <input>
            <type>Slider</type>
            <value>Volume_Player</value>
            <bytes>B0 1C VH</bytes><bytes_low>B0 2C VL</bytes_low>
            <player>0</player>
            <invert>no</invert>
         </input>
         <input>
            <type>Slider</type>
            <value>Volume_Player</value>
            <bytes>B1 16 VH</bytes><bytes_low>B1 26 VL</bytes_low>
            <player>1</player>
            <invert>no</invert>
         </input>
      </tab>
   </tabs>

It's not working.


Am I totally missing something here or is this a bug/not implanted?

_________________
Musician/DJ: Soundcloud
Designer: Serato Scratch Live Skin for djDecks :: *Download* *Topic* *Facebook*


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: Bing [Bot] and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group